# Exception on server

**URL:** <https://community.temporal.io/t/exception-on-server/9310>\
**Category:** Community Support\
**Created:** [August 25, 2023, 8:31pm UTC](https://community.temporal.io/t/exception-on-server/9310 "2023-08-25T20:31:49Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![quadra](https://avatars.discourse-cdn.com/v4/letter/q/b3f665/32.png) [@quadra](https://community.temporal.io/u/quadra)\
**Post date:** [August 25, 2023, 8:31pm UTC](https://community.temporal.io/t/exception-on-server/9310/1 "2023-08-25T20:31:49Z")

</div>

My server is been configured to use this configuration:

```
  - TEMPORAL_JWT_KEY_SOURCE1=http://keycloak:9595/realms/gravity/protocol/openid-connect/certs
  - TEMPORAL_AUTH_AUTHORIZER=default
  - TEMPORAL_AUTH_CLAIM_MAPPER=default

```

I am getting following exception during startup:

{“level”:“fatal”,“ts”:“2023-08-25T20:21:08.342Z”,“msg”:“error starting scanner”,“service”:“worker”,“error”:“Request unauthorized.”,“logging-call-at”:“service.go:520”,“stacktrace”:“[go.temporal.io/server/common/log.(\*zapLogger).Fatal](http://go.temporal.io/server/common/log.(*zapLogger).Fatal)\n\t/home/builder/temporal/common/log/zap\_logger.go:180\ngo.temporal.io/server/service/worker.(\*Service).startScanner\n\t/home/builder/temporal/service/worker/service.go:520\ngo.temporal.io/server/service/worker.(\*Service).Start\n\t/home/builder/temporal/service/worker/service.go:404\ngo.temporal.io/server/service/worker.ServiceLifetimeHooks.func1.1\n\t/home/builder/temporal/service/worker/fx.go:136”}

Do you have any idea why?

---

<div class="post-metadata">

**Author:** ![gautam.g4](https://sea2.discourse-cdn.com/flex016/user_avatar/community.temporal.io/gautam.g4/32/4052_2.png) [@gautam.g4](https://community.temporal.io/u/gautam.g4)\
**Post date:** [September 1, 2023, 12:25pm UTC](https://community.temporal.io/t/exception-on-server/9310/2 "2023-09-01T12:25:12Z")

</div>

Hi Quadra,

Were you able to find a solution for this issue? I’m facing the same issue, are you using the mTLS setup in the temporal along with the SSO setup? I have provided the TEMPORAL\_JWT\_KEY\_SOURCE1, TEMPORAL\_AUTH\_AUTHORIZER, and TEMPORAL\_AUTH\_CLAIM\_MAPPER. When the docker is run we get the same error after which the temporal server shuts down.

If anyone can provide inputs on how to proceed, it would be great.

Kind Regards,  
Gautam
