# Not able to view archieved worflows from s3

**URL:** <https://community.temporal.io/t/not-able-to-view-archieved-worflows-from-s3/17539>\
**Category:** Community Support\
**Tags:** s3, archival\
**Created:** [May 28, 2025, 9:23am UTC](https://community.temporal.io/t/not-able-to-view-archieved-worflows-from-s3/17539 "2025-05-28T09:23:30Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![madhu](https://avatars.discourse-cdn.com/v4/letter/m/a8b319/32.png) [@madhu](https://community.temporal.io/u/madhu)\
**Post date:** [May 28, 2025, 9:23am UTC](https://community.temporal.io/t/not-able-to-view-archieved-worflows-from-s3/17539/1 "2025-05-28T09:23:30Z")

</div>

i am running temporal 1.27.2

i have a namespace where archival is enabled usig s3, i see old workflows getting archived in my s3 buckets.

however from the webui or from temporal cl i am not able to retrive workflows

when i issue a command like

> temporal workflow list --archived --namespace mynamespace

i get

> time=2025-05-28T09:20:43.476 level=ERROR msg=“failed listing workflows: context deadline exceeded”

in my front end log i see

> {“level”:“error”,“ts”:“2025-05-28T08:41:55.170Z”,“msg”:“service failures”,“operation”:“ListArchivedWorkflowExecutions”,“wf-namespace”:“mynamespace”,“grpc\_code”:“Unavailable”,“error”:“RequestCanceled: request context canceled\ncaused by: context canceled”,“logging-call-at”:“/home/runner/work/docker-builds/docker-builds/temporal/common/rpc/interceptor/telemetry.go:423”,“stacktrace”:"[go.temporal.io/server/common/log.(\*zapLogger).Error](http://go.temporal.io/server/common/log.(*zapLogger).Error)\n\t/home/runner/work/docker-builds/docker-builds/temporal/common/log/zap\_logger.go:154\ngo.temporal.io/server/common/rpc/interceptor.(\*TelemetryInterceptor).logErrors\n\t/home/runner/work/docker-builds/docker-builds/temporal/common/rpc/interceptor/telemetry.go:423\ngo.temporal.io/server/common/rpc/interceptor.(\*TelemetryInterceptor).HandleError\n\t/home/runner/work/docker-builds/docker-builds/temporal/common/rpc/interceptor/telemetry.go:393\ngo.temporal.io/server/common/rpc/interceptor.(\*TelemetryInterceptor).UnaryIntercept\n\t/home/runner/work/docker-builds/docker-builds/temporal/..

another thing i noticed is the log in front end happens immediately, while the tctl context dead line exceeds happens after a while.
