Do Not Include Arguments Into Marker

We used setDoNotIncludeArgumentsIntoMarker(true) to disable the writing of request/response in Cassandra for local activities, but it did not work. Request/response are still getting logged.

Not sure if I am missing anything.

If you set DoNotIncludeArgumentsIntoMarker to true only the arguments of the local activity are not included in the marker event. The result is still recorded.

Do you see the type->payloads element in the marker recorded event details? If so which SDK version are you using?

Hi @tihomir , we still see payloads in the recorded events. We use SDK 1.14.0.

@tihomir Please let me know if this option works with the SDK version 1.14.0.

There were no changes/fixes to DoNotIncludeArgumentsIntoMarker on the SDK side since 1.14 and It seems to work as expected when tested. Whats the server version you are using?

Could you provide a reproduce, I’d be glad to test it out as well.

One thing you can test is HelloLocalActivity sample against 1.14. When running it as is the marker recorded details unclude

{
  "input": {
    "payloads": [
      "Hello",
      "World"
    ]
  }
}

then set .setDoNotIncludeArgumentsIntoMarker(true) in LocalACtivityOptions and run the sample again. and test that input is not recorded. Let me know if you see the same thing.