I may be mistaken but I think I’m looking at an error in example code in the “Testing Workflows” lesson of the Java 102 course.
@WorkflowInterface
public interface SumOfSquaresWorkflowImpl{
@WorkflowMethod
int calculateSumOfSquares(int first, int second);
}
public class SumOfSquaresWorkflowImpl implements SumOfSquaresWorkflow {
Should the name of the interface be SumOfSquaresWorkflow
rather than SumOfSquaresWorkflowImpl
?