Error when temporal bench test by maru

I have a local temporal cluster, and I want to run the bench test according to maru, but when I run the command line “tctl wf start --tq temporal-bench --wt bench-workflow --wtt 5 --et 1800 --if ./scenarios/basic-test.json --wid 1”, I get error “basic-test.json: no such file or directory”, I really check this relative path is right. How can I fix it ? Thanks a lot.

Hi @haojie ,

I am unable to reproduce this issue. Can you please check the tctl command in the base dir of the maru repository that you cloned? Secondly, can you double check if you are in the worker directory? Lastly, can you please send me a screenshot of what you are seeing when you try to execute this?

Best Regards,

Thanks for reply. I have checked all, and I try the absolute path , but it does not make sense.

Can you send a screenshot of the directory that you are using? You can do so by running ‘pwd’.

pwd = /home/haojie/git/maru
I’m sure I run the command in the base directory of maru repo, and why I use absolute path, it still dose not make sense.

There is something wrong with tctl. Before I run the temporal-admin-tools docker image:1.16.1 and create a tctl alias, the above problem arised. However I build tctl locally, the verision of tctl is 1.16.2, and it works fine.

Can you change your directory to worker? Afterwards please try running the command tctl wf start --tq temporal-bench --wt bench-workflow --wtt 5 --et 1800 --if ./scenarios/basic-test.json --wid 1

Can you check the tctl version on the admin tools image:
tctl -v
This would help reproduce the issue locally.