[SERVER] Set FrontEnd IP on Worker Service

My worker app is unable to verify if the namespace exist. I am also wondering why its checking its own IP and PORT instead of the IP of front end service ? What environment variable should I put on the worker app so it can talks to the right frontend IP ?

  • deployment : AWS ECS
  • version : 1.10.2
    "level": "warn",
    "ts": "2021-07-01T06:59:10.398Z",
    "msg": "unable to verify if namespace exist",
    "Namespace": "temporal-system",
    "TaskQueue": "temporal-sys-tq-scanner-taskqueue-0",
    "WorkerID": "13@ip-10-247-36-66.ap-southeast-1.compute.internal@",
    "WorkerType": "WorkflowWorker",
    "Error": "last connection error: connection error: desc = \"transport: Error while dialing dial tcp connect: connection refused\"",
    "logging-call-at": "internal_worker.go:258"

Apparently setting PUBLIC_FRONTEND_ADDRESS makes the problem go away. But why? I thought that the worker should automatically detect the private IP of the frontend service and talk to it.

So basically this solution only work when we are using the Private IP instead of the LB private dns. Any idea why ?