Elastic search version compatibility

Hi i think this has been bought up previously. I have managed to set up temporal with advanced visibility using ES, however its not running properly with any of the 7.x versions. I run into the following error when the ListAllWorkflows api is called Types cannot be provided in put mapping requests, unless the include_type_name parameter is set to true.
I tried with 6.8 and this error seems to vanish and i did come across some literature that said adding type got removed in later es versions.
However in 6.8 i did get another error Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [RunId] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.
This was easily resolved by running the following cURL
curl --location --request PUT ‘http://localhost:9200/temporal-visibility-dev/_doc/_mapping
–header ‘Content-Type: application/json’
–data-raw ‘{
“properties”: {
“WorkflowType”: {
“type”: “text”,
“fielddata”: true
Is this expected behaviour? Also how soon are you guys planning to test on 7.x versions?

The V1.0 release of Temporal is tested with version 6.8.8 of Elastic Search version. We have plans for supporting 7.X as tracked by issue #313, but don’t have a timeline yet.

As for the issue you are running with 6.8, can you provide more details about how you are setting up the schema? Here is how we create index for visibility. And this is how is it registered with Elastic Search when the docker container comes up. We use keyword type rather than text type for both RunId and WorkflowType.

Thanks this helped, i was deploying individual services using make and ./temporal-server without using docker (just to understand each of the services and what their scope is) i guess thats why these commands did not get executed.