Elasticsearch for Temporal (version, incident_raised_date, auto_create_index)


I need to use ElasticSearch for Temporal and have couple question:

  1. Will ElasticSearch 7.6 works for Temporal 1.13? If not then what is recommended version?
  2. I am using ElasticSearch 7.6 for Temporal 1.13 currently and get the following replied from ElasticSearch → “incident_raised_date”:“0001-01-01T00:00:00Z”, is it due to incompatible version for Elastic Search?
  3. Currently ElasticSearch receives action (in persistent area) → “auto_create_index” : “false”, is it a mandatory for temporal to function to set auto_create_index to false? Can temporal work if auto_create_index is set to true? Is this parameter can be set / change? If yes then in which file?

Many thanks and regards,


Sorry for delay, redwan.

  1. 7.6 should work, although it wasn’t tested. 7.10 is what we tested. You can read more about dependencies and its versions here.
  2. This is just a part of error message. Can you paste entire error message here? I doubt that it is because of 7.6.
  3. It is not required and you can leave it as true there. There reason we set it to false is that if you have a typo in index name in your config, Elasticsearch will create this index automatically w/o appling index template and it will lead to weird errors. Just double check index name in your config file and leave the default for auto_create_index.

Hi Alex,

Many thanks for your feedback.

(1) Noted
(2) This one is fixed, it turns out cannot use this format: 1900-01-01T00:00:00+07:07 so need to use this format: 2022-01-04T15:31:06.263843247Z
(3) How to leave out auto_create_index? Isn’t it default from Temporal framework to set auto_create_index to false?

Thanks & regards.

More info for point (3), temporal will send this to ElasticSearch:
PUT _cluster/settings
“persistent”: {
“action.auto_create_index”: null
And this somehow will set auto_create_index to false.
In which file we can comment out this setting?


If I’m not mistaken that should be in the cluster_settings files here: temporal/schema/elasticsearch/visibility at master · temporalio/temporal · GitHub

Hi tihomir,

Yes correct, I found it. Many thanks your info.