Error installing Temporal using helm

Hello,

I’m trying to install Temporal using helm based on the instructions found here: https://github.com/temporalio/helm-charts

When I run the following command, I get the error “Error: create: failed to create: Request entity too large: limit is 3145728”. Any ideas about this?

helm install
–set server.replicaCount=1
–set cassandra.config.cluster_size=1
–set prometheus.enabled=false
–set grafana.enabled=false
–set elasticsearch.enabled=false
–set kafka.enabled=false
temporaltest . --timeout 15m

Could it be something in the same directory?

Thanks for your reply. All I did was run the following “helm dependencies update” and it created a charts folder with the following contents.
1417 cassandra-0.14.3.tgz
23083 elasticsearch-7.6.2.tgz
19490 grafana-5.0.10.tgz
41268 kafka-7.2.9.tgz
32899 prometheus-11.0.4.tgz

The file sizes don’t exceed 3MB. I then run the helm install command provided as shown below and get the error. I don’t understand what file size it is complaining about.

helm install
–set server.replicaCount=1
–set cassandra.config.cluster_size=1
–set prometheus.enabled=false
–set grafana.enabled=false
–set elasticsearch.enabled=false
–set kafka.enabled=false
temporaltest . --timeout 15m

I figured out the problem, I didn’t checkout the whole repo and was only using the Chart.yaml. Thanks for your assistance.

1 Like