Errors while setting up Temporal on local environment using helm chart

I am trying to do a POC for a business process using Temporal. I am facing errors while setting up temporal locally with Kubernetes on MAC OS. I tried the instructions provided here, GitHub - temporalio/helm-charts: Temporal Helm charts.

This is the pod status after deploying the temporal using helm charts:

$$kubectl get pods
mysql-1633380845-0 1/1 Running 7 3h1m
temporaltest-admintools-7f5c4db86d-brvbs 1/1 Running 0 25m
temporaltest-cassandra-0 1/1 Running 0 25m
temporaltest-frontend-58f895fd57-c8cgh 0/1 CrashLoopBackOff 7 25m
temporaltest-history-57bccb54fd-59h9s 0/1 CrashLoopBackOff 7 25m
temporaltest-matching-76598d78bc-c82xx 0/1 CrashLoopBackOff 7 25m
temporaltest-web-6dd9b4f97b-r2gdx 1/1 Running 0 25m
temporaltest-worker-8669cb678-xjw4l 0/1 CrashLoopBackOff 7 25m

I tried to look at the logs for the issues: found this ERROR:
** server can’t find temporaltest-cassandra.default.svc.cluster.local: NXDOMAIN

*** Can’t find temporaltest-cassandra.default.svc.cluster.local: No answer

waiting for cassandra service



TIA for the help.

Cassandra service is coming up successfully and under the environment i see the value of CASSANDRA_SEEDS as temporaltest-cassandra-0.temporaltest-cassandra.default.svc.cluster.local

@mhk007 Thanks for the info, we are aware of the issue and are looking into it. Will update with more info as soon as its available.

For your POC, to get you running until we have a fix for the helm charts, you can deploy the server on docker compose - GitHub - temporalio/docker-compose: Temporal docker-compose files

We are working on providing the fixes for helm-charts on the master branch.
Did find a quick workaround for now to get you started, in the helm-chart repo revert to an older commit, particularly:
git reset --hard f205bcecc83f4a8e92c08ff1936fdbef68164e21
and run the same helm command as you are doing now.
Note that this is just a temp fix until we resolve the problem on the top of master branch.
Let me know if this heps.

Thanks, @tihomir, I actually did the same and it helped!

Just an update, but I fixed this at head. Guard security context based on appVersion by krousey · Pull Request #232 · temporalio/helm-charts · GitHub

The root cause was a failed write to a file due to permission issues. The Dockerfile at head has been modified to support the security context, but past releases don’t support it.