How do I set HistoryCountLimitError and HistoryCountLimitWarn when I'm deploying Temporal using Helm chart

We are trying to avoid the HistoryCountLimitError and HistoryCountLimitWarn by configuring this higher in our local deployment. Need help on this.

We don’t recommend changing these values as setting them too high does can compromize system stability. The right solution is to refactor your application so that it never exceeds the default limits.

1 Like

We understand it might be unstable, but I’m doing a POC for doing performance testing which needs this change. Could you point me in the right direction?

I’m confused. If it is POC, then you have even fewer reasons to change these values.