Persistence.DataStores[default](value).Cassandra.Hosts: zero value, Persistence.DataStores[visibility](value).Cassandra.Hosts: zero value

Hi All,

Please help, I tried to run the temporal image and got this error, although I use the latest image from temporal (using docker pull temporalio/auto-setup:latest).

2022/04/03 11:46:32 Loading config; env=docker,zone=,configDir=config
2022/04/03 11:46:32 Loading config files=[config/docker.yaml]
Unable to load configuration: config file corrupted: Persistence.DataStoresdefault.Cassandra.Hosts: zero value, Persistence.DataStoresvisibility.Cassandra.Hosts: zero value.

The command for docker run (use the download image):

docker run -d --name=temporal-server -it 1c230ac834b5 --network=host -e “BIND_ON_IP=192.168.1.15” -e “DB=cassandra” -e “CASSANDRA_SEEDS=192.168.1.15” -e “CASSANDRA_PORT=9042” -e “ENABLE_ES=true” -e “ES_SEEDS=192.168.1.15” -e “ES_PORT=9200” -e “NUM_HISTORY_SHARDS=60”

But if I run this command, seems to be working:

docker run -d --name=temporal-server --network=host -e “BIND_ON_IP=192.168.1.15” -e “DB=cassandra” -e “CASSANDRA_SEEDS=192.168.1.15” -e “CASSANDRA_PORT=9042” -e “ENABLE_ES=true” -e “ES_SEEDS=192.168.1.15” -e “ES_PORT=9200” -e “NUM_HISTORY_SHARDS=60” docker.io/temporalio/auto-setup

Did I do something wrong?

regards,

ridwan

Hi All,

Just solved, it turns out cannot use image id, must use image name.

1 Like