Seeing new error in workflow activation

I am using the temporal typescript sdk and we randomly started seeing this error message being logged:

2023-10-23T17:58:19.686420Z  WARN complete_workflow_activation: temporal_sdk_core::worker::workflow: Error while completing workflow activation error=status: InvalidArgument, message: "search attribute TemporalChangeVersion is not defined", details: [], metadata: MetadataMap { headers: {"content-type": "application/grpc"} } completion=WorkflowActivationCompletion(run_id: de5adff8-c692-47ba-a111-8c6dc19b0b90, status: Success(SetPatchMarker(isolated-nanoid) StartChildWorkflowExecution(1, executePipelineNode) )) run_id=de5adff8-c692-47ba-a111-8c6dc19b0b90 task_queue=test workflow_id="start-task-6536b42f3e61ef2dd2cdf26e"

Any guidance on how we can solve this?

i am confused because this seems like it’s not code related… i have checked out a quite old commit (where it definitely worked before) and I get the same error

this is happening inside the startChild of a parent workflow for more information

for more information i am using await TestWorkflowEnvironment.createTimeSkipping to create a temporal server for testing.


    testEnv = await TestWorkflowEnvironment.createTimeSkipping({
      // For some reason this is still faster than createLocal
      client: { enableTimeSkipping: true } as any,
      server: {
        executable: {
          version: 'v1.20.0',
          type: 'cached-download',

seemed to have fixed the issue. Someone should look into the latest java SDK release for this bug.

This is due to us upgrading the time skipping test server just recently. The SDK’s test framework automatically downloads the “best” version of that server and caches it locally.

This issue was fixed over the weekend and just released a few hours ago.

If you’re running tests locally, it’s likely that the download is cached by the SDK in your tmp directory.
You’ll need to delete that file.

On my Mac, I saw it installed at /var/folders/g3/xthbnf8n659_sr46q7ghslhc0000gn/T/temporal-sdk-typescript-1.8.6.