[SOLVED] "context deadline exceeded" & "Not enough hosts to serve requests" errors

I just deployed a temporal cluster in my company k8s with the official helm charts using the minimum config with a backing postgres.
When I tried to run the hello world workflow, it failed and reported “context deadline exceeded”.
The temporaltest-frontend logs said “Not enough hosts to serve requests”.

Seems to me a network issue with the k8s deployment. I assume there might be certain network settings I hadn’t done.
But in fact I can use tctl to create and list namespace, and the worker I ran locally could create the client connection.

Any idea where I could have gone wrong?

Figured it out myself.
Realized that the temporaltest-history didn’t start due to limited resource quota to our namespace.
But kubectl get pods didn’t show the temporaltest-hisotry pod, so I easily missed that out.
kubectl describe events came to rescue.
I had to specify resources in the chart to fix the issue.

1 Like