Temporal Server cannot starts and unable to bootstrap ringpop

Hi All,

I have started matching and history docker and seems like it is waiting for Temporal Server to start, then I run the docker for FrontEnd and it also waiting for Temporal Server to start but cannot start until it hits another error: unable to bootstrap ringpop. retrying,service:frontend,error:join duration of 38.765946996s exceeded max 30s".

I used the docker run command below. Please help.

docker run -e SERVICES=frontend -d --name=temporal-server-frontend -e LOG_LEVEL=debug,info -e “BIND_ON_IP=” -e “TEMPORAL_CLI_ADDRESS=temporal-server-frontend:7233” -e “CASSANDRA_PORT=9042” -e “CASSANDRA_SEEDS=” -e “DB=cassandra” -e “ENABLE_ES=true” -e “ES_SCHEME=http” -e “ES_SEEDS=” -e “ES_PORT=9200” -e “ES_VERSION=v7” -e “ES_VIS_INDEX=temporal_visibility_v1_nft” -e “TEMPORAL_CLI_NAMESPACE=grouporder-namespace” -e “NUM_HISTORY_SHARDS=20” -e “CASSANDRA_REPLICATION_FACTOR=1” -e “ES_USER=” -e “ES_PWD=” -e “DYNAMIC_CONFIG_FILE_PATH=config/dynamicconfig/development.yaml” temporalio/auto-setup:latest

Thanks & regards,


Do you set TEMPORAL_BROADCAST_ADDRESS env var and to which value? See config template.

Hi Tihomir,

I tried to set to docker IP address for history server docker (, matching server ( and FrontEnd ( but still get same problem.

solved, I used the wrong IP for the TEMPORAL_BROADCAST_ADDRESS