Temporal_visibility keyspace cannot be created in cassandra when replication factor is more than 1


Currently if I change CASSANDRA Replication Factor to more than 1, temporal cannot create temporal_visibility keyspace in Cassandra (after successfully create temporal keyspace in Cassandra) with the error:
{“level”:“info”,“ts”:“2022-01-07T08:45:10.847Z”,“msg”:“Starting server for services”,“value”:[“history”,“matching”,“frontend”,“worker”],“logging-call-at”:“server.go:123”}
Unable to start server. Error: cassandra schema version compatibility check failed: unable to read DB schema version keyspace/database: temporal error: failed to get current schema version from cassandra

But if Cassandra Replication Factor is 1, it does not generate this error.
Any thought?


Can you talk about you are deploying temporal? The temporal-cassandra-tool can use whatever rf you want if you use network topology for replication.

The default is simple with rf 1. Which is maybe why it worked?

Hi, we are deploying temporal in OCP pod (OCP 4).
If using default simple with rf 1 is working, but other than rf 1 then get error in setuptask.go line 119:
err := task.db.UpdateSchemaVersion(config.InitialVersion, config.InitialVersion)
if err != nil {
return err

How to set network topology for replication in temporal? And how to use temporal-cassandra-tool?


Just to update, this already solved
It turns out the chrony (time) is not sync between cassandra nodes.
After sync time, it can create keyspace with RF=3.