Config ringpop production

Hello community! Even though I can register domains also view them from the cadence website, I am seeing the server logs and the error is constant:

{"level":"error","ts":"2020-08-10T18:57:58.372Z","msg":"Internal service error","service":"cadence-frontend","error":"InternalServiceError{Message: Not enough hosts to serve the request}"

The RINGPOP_BOOTSTRAP_MODE=hosts variable has this default value, but what other value can I give it?

From what I see in a configuration with docker-compose the value of RINGPOP_SEEDS= is by default, but if I replace it bootstrapHosts would take the HOST_IP values ​​and the truth is that I don’t know why value to replace it.


Hey there Nicolas! Ringpop bootstrap hosts are the initial hosts that brand new hosts communicate too in order to join the cluster. Hosts mode requires you to provide a list of hosts, so in that mode, you would want to provide the IP addresses of a few currently running hosts with stable IP addresses.

If you are running on a single host, should be the value used. If you have non-stable IP addresses, there is also a dns mode where you can specify a dns name that you would manage yourself to keep in sync with cluster IP addresses.

Have you looked at upgrading to Temporal? Temporal does away with these configuration options and brokers these addresses through the persistence layer, heavily simplifying operation in this area.

Hello, thank you very much for your answer. I tried to hand over that host but it didn’t work. What did work was to deliver and the other ports of the services. But I am left wondering what happens if I scale the service in my cluster, if that IP is no longer the same but several different ones, it will probably present the same error.

Regarding the second, of course I have thought about it, only that for now due to the project we cannot change cadence since it was a management decision :frowning: