Cron Schedule timing

Hi Thiomir,

I had created one cron job and wanted it to run daily by say 9 pm IST , I am trying to configure it in application properties as @daily and using the pattern that is mentioned on cron website, but getting error as INVALID_ARGUMENT : Invalid CronSchedule.

Could please provide one example so that I can have a reference.

I had also tried with this pattern @daily * * * * * * with some values but didn’t worked for me.

Hello @Manish_Baraskar

It looks like @daily * * * * * * not a valid input Workflows | Temporal Documentation, setting only @daily is gonna schedule the cron to run at midnight, equivalent to 0 0 * * * ,

Default timezone for cron jobs is UTC and the recommendation is to set the cron schedule in UTC

You can specify the timezone, e.g. if you want your cron to run daily at 9 pm IST you can do CRON_TZ=Asia/Kolkata 0 21 * * * (I think that IST is Asia/Kolkata)
see Workflows | Temporal Documentation

Hi @antonio.perez

I think it is working thanks a lot. Was not aware about this different syntax.