Temporal on kubernetes

I have temporal server hosted on kubernetes

I have to connect my worker api to the remote hosted temporal server . I tried using this but its not able to connect - is there something else i should be using?

I replaced host with the host name and IP with 80 ( thats the ingress created)

WorkflowServiceStubs service =

I assume your worker process is not deployed on the same cluster right?
Did you create an ingress controller? Does it expose a public ip/port? This kubernetes doc might help.

Thanks I will try this
Will having my worker application in same cluster as temporal server help ?

@tihomir - i deployed it in the same cluster but I am getting this error - not sure why? Any idea?
Caused by: io.grpc.netty.shaded.io.netty.handler.codec.http2.Http2Exception: First received frame was not SETTINGS. Hex dump for first 5 bytes: 485454502f

Hi @sreepadma
Can you confirm if you are using the temporal-frontend-headless service ?
I was getting the same problem , but figured I was connecting the client to the temporal-worker-headless service, which got solved when I hit the frontend-service.