"Unable to parse decrypted password" error in Temporal Panel

I used to be able to replay workflows using the Temporal extension in VS Code by opening the Temporal Panel and pasting the Workflow Id of a recent workflow.

But now I’m seeing the following error at the bottom right and the workflow doesn’t launch when i click Start: “Error: unable to parse decrypted password”


Could you try resubmitting the credentials in the settings tab?

The Settings panel hangs (see attached screenshot). I tried re-installing the extension but still no luck. It somehow remembers what I’d entered as the path to debug-replayer.ts. Do you know where in a Mac this info is stored by this extension so I can make the extension reload from scratch? I deleted ~/.vscode/extensions/temporal-xx but that didn’t make a difference.

Also: I’m running a local Temporal instance and there is no need for any password. It used to work. So I’m not sure what is the “decrypted password” referring to.

I wonder if reinstalling the extension would solve this. I don’t know what’s happening, I would need to debug it but I can’t reproduce myself.
What VS Code version are you running? Is anything logged to the editor’s console?
I’ll look into how you can provide more debug information if you are willing to help.