Creating domain with cli is giving error

Hi team, Is something changed regarding domain registration from cli? I am getting error using this command:

docker run --net host --rm ubercadence/cli:master --domain test-domain-2 domain register --global_domain false

Cadence frontend service error logs:

{"level":"error","ts":"2020-07-13T17:30:46.234Z","msg":"Uncategorized error","service":"cadence-frontend","error":"BadRequest: Bad Request\n\tstatus code: 400, request id: CFF14888DC5901E5, host id: QELJXOA7o9VXsFCcf2W0L7W/Jv8JuDrBhWIfAQYcBVgRgMnDGE2JyC5iA443cjwauxZgKmj/yBQ=","logging-call-at":"workflowHandler.go:3497","stacktrace":"*loggerImpl).Error\n\t/cadence/common/log/loggerimpl/logger.go:134\*WorkflowHandler).error\n\t/cadence/service/frontend/workflowHandler.go:3497\*WorkflowHandler).RegisterDomain\n\t/cadence/service/frontend/workflowHandler.go:279\*DCRedirectionHandlerImpl).RegisterDomain\n\t/cadence/service/frontend/dcRedirectionHandler.go:177\*AccessControlledWorkflowHandler).RegisterDomain\n\t/cadence/service/frontend/accessControlledHandler.go:467\\n\t/cadence/.gen/go/cadence/workflowserviceserver/server.go:1033\\n\t/go/pkg/mod/\*Middleware).Handle\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\\n\t/go/pkg/mod/\*Connection).dispatchInbound\n\t/go/pkg/mod/"}

1 Like

Please don’t use master as we are constantly doing backwards incompatible changes.

Make sure to use v0.26.0 (or whatever the latest release at the time you read this) of both service docker and the tctl docker.

Hi Maxim, I am using ubercadence in that only master is available. So there might be some bug in the master version?

Are you running the master version of the service as well using docker-compose?

No, I m using latest release 0.13.0 for server and running using kubernetes

Then I would recommend using the same version of the CLI docker instead of the master one.

Hi Maxim, figure the issue. My config archival settings are not correct due to this it’s failing. I verified this by removing archival settings and it worked and also after I corrected archival settings it worked again. The strange thing is logs are not very helpful to tell me that the archival section is creating a problem.